02 WRX swapped GC Overboosting

Discussion in 'Modifications And Maintenance' started by 02subbieRS, Mar 11, 2018.

  1. 02subbieRS
    Offline

    02subbieRS Well-Known Member

    Likes Received:
    111
    Trophy Points:
    128
    Hey everybody! More adventures in subbie swap land!

    Background for integrity's sake:
    2002 WRX swapped 1998 2.5 RS
    unknown boost control solenoid (See below)
    aftermarket turbo (no real idea what it is, came installed on the bugeye)
    modded stock injectors (previous owner)
    walbro 255

    After getting my gauges installed on Saturday, took the car for a rip to see if I was still rubbing tire after I rolled the fenders, and lo and behold, ALL OF THE BOOST!!!!!! Pegged my 30PSI gauge for a second maybe two tops. Did a few short pulls and it easily kept going past the 20PSI it hit when it was in the bugeye.


    [​IMG]

    Left hose: Compressor Housing
    Top Right Hose: Wastegate Actuator
    Bottom Right Hose: Turbo Inlet Duct towards the front of the engine <---This is the part that confuses me a bit.

    Anyone ever seen one like it? It's possible I could have it plumbed incorrectly. Any help is greatly appreciated :)
     
  2. pleiades
    Offline

    pleiades Well-Known Member

    Likes Received:
    553
    Trophy Points:
    178
    I couldn't tell you if that's plumbed right or not, but if you need a new one I have a couple spare boost controllers. One is a Pierburg 3-port EBCS and the other is a Grimmspeed MBCS. Had them both listed on here for sale a while back at $50/ea but shoot me an offer if you want either or both.
     
  3. MrBlue
    Offline

    MrBlue Active Member

    Likes Received:
    353
    Trophy Points:
    73
    Googled Delphi... BCS from a diesel, find the part # on it you might be able to interweb a diagram
     
    02subbieRS likes this.
  4. tangledupinblu
    Offline

    tangledupinblu Event Coordinator Staff Member

    Likes Received:
    6,098
    Trophy Points:
    573
    Lol, diesullz! Good luck my brotha, hope that this is a quick/easy fix!
     
    02subbieRS and MrBlue like this.
  5. JasonoJordan
    Offline

    JasonoJordan Well-Known Member

    Likes Received:
    1,410
    Trophy Points:
    298
    Should be able to disconnect the line running to the WG actuator and test it out and make sure that its not another issue. With the line disconnected you should have around WG spring pressure so apx 10psi. Thats provided that the wg actuactor is similar to stock and not some crazy high spring rate.
     
    02subbieRS likes this.
  6. idget
    Offline

    idget Want to pokéman? PM ShortytheFirefighter Staff Member

    Likes Received:
    3,938
    Trophy Points:
    398
    That's almost definitely a GM BCS (off the typhoon and other cars from that era). Really popular, cheap mod from back 10-15 years ago on wrx/sti's. GM Part # 1997152 and GM Part # 12102747 if you want to cross reference to confirm.

    Looks like your vent and wastgate hoses are interchanged. Top right should vent to atmosphere (or plumb back to intake) and bottom right should go to wastegate... which explains your overboost. Swap those hoses and ease into boost. Log it via the ecu rather than your gauge too. Also, go get a tune.
     
    02subbieRS likes this.
  7. 02subbieRS
    Offline

    02subbieRS Well-Known Member

    Likes Received:
    111
    Trophy Points:
    128
    Thanks everyone! Appreciate all the quick help.

    Will definitely swap those hoses around and give it a shot Sheen. The more I work on this thing, the more it solidifies that the previous owner was a cheap a**!
    Currently don't have logging capabilities. Hoping my buddy will be over this weekend to lend me a hand since he's got a tactrix cable and some experience.

    A tune is right on my list after I get an alignment once the roads are salt free. Gotta take it easy to break in the clutch before the tune. It WILL get tuned :)
     
    idget likes this.

Share This Page