WTB: charcoal canister 01 Forester

Discussion in 'Want To Buy : Cars/Parts' started by predavore, Jun 17, 2018.

  1. predavore
    Offline

    predavore Well-Known Member

    Likes Received:
    296
    Trophy Points:
    268
    Looking for a lower mileage charcoal canister. Just put gas in the tank and threw a p1443 evap code.

    Thanks
     
  2. Krazylegz1485
    Offline

    Krazylegz1485 Well-Known Member

    Likes Received:
    1,752
    Trophy Points:
    173
    Is your solenoid valve alright? For some reason my car has toasted a couple of them (like actually melted the plastic surround). Kinda weird.

    If I had access to an open source thing I think I'd just delete all that crap and delete the associated CEL codes. Mine does the stupid doesn't wanna pump gas steadily thing quite frequently.
     
  3. predavore
    Offline

    predavore Well-Known Member

    Likes Received:
    296
    Trophy Points:
    268
    Not sure. Is it separate from the EVAP canister?

    Is that possible to do?

    When I first bought the car 2 years ago, it did that and I put in a junkyard canister and problem solved.

    I've gotten a couple p0420 codes here and there. But then the last one was the p1443. It happened right after filling up the tank. No problems with filling. But I swear I heard a slow pssshhhh sound like it was struggling to suck or blow air. Hardly audible, thought it was my imagination until the CEL lit.

    P1443 Evaporative emission control system vent control function problem
     
  4. Krazylegz1485
    Offline

    Krazylegz1485 Well-Known Member

    Likes Received:
    1,752
    Trophy Points:
    173
    I have an 03 WRX so it might be slightly different, but I'm guessing they're similar at least. Also, I'm no Subaru tech just sharing my personal experiences. It may or may not help at all.

    Anywho, the part I replaced is a little solenoid valve that the hoses from the canister connect to. I think it's job is to just open and close, diverting the fumes wherever they need to be at the time, I guess. My codes seemed to be totally intermittent, but I noticed my fuel fill up being difficult for a while. Replaced that part and it went away immediately. Has since happened again randomly but I've found that if I put the nozzle in and turn the handle to 10 o'clock (6 being normal) it works fine every time. So screw it.

    As far as deleting it goes, I know you can, I just personally haven't done it yet. Apparently it's pretty straightforward and easy, the only downside is you have to get the codes cleared permanently. There's a port on the intake to block off and then some excess fuel lines and what not to remove. Plus all that crap at the rear, of course.

    I don't know that there's either a positive or negative result tied to this other than never having to deal with the fuel filling issue, but if I get another bugeye or something I'll probably just get rid of it all right away. That and the stupid "did you put the gas cap on right" code?

    Emissions shmeshmissions...
     
    tangledupinblu likes this.
  5. predavore
    Offline

    predavore Well-Known Member

    Likes Received:
    296
    Trophy Points:
    268
    Did you get a CEL code with that? I'm OK with replacing a valve if it's not part of the canister. But the code seems very specific to replacing the canister. I might need to replace it again.
     
  6. tangledupinblu
    Offline

    tangledupinblu Event Coordinator Staff Member

    Likes Received:
    6,005
    Trophy Points:
    573
    You should be able to “delete” the codes for them.
     
  7. predavore
    Offline

    predavore Well-Known Member

    Likes Received:
    296
    Trophy Points:
    268
    "You" or "I"...
     
  8. Krazylegz1485
    Offline

    Krazylegz1485 Well-Known Member

    Likes Received:
    1,752
    Trophy Points:
    173
    I did, but honestly don't remember exactly what it was as it's been a while with no issues. I might've made a post on here about it at the time so I'll see if I can find that.

    In the meantime, a quick Rock Auto search yields me this for a solenoid valve:

    [​IMG]

    Unfortunately it's like $50 so kind of a spendy shot in the dark. However, if you find a donor canister from a junkyard Forester you could maybe just snag the valve at the same time?

    Not sure where you're located but an 01 Forester just got placed at the East Bethel U Pull the other day (6/12).

    [​IMG]
     
  9. Krazylegz1485
    Offline

    Krazylegz1485 Well-Known Member

    Likes Received:
    1,752
    Trophy Points:
    173
  10. tangledupinblu
    Offline

    tangledupinblu Event Coordinator Staff Member

    Likes Received:
    6,005
    Trophy Points:
    573
    “Someone” with tha data logging/toonin abilities.
     
    Krazylegz1485 likes this.
  11. predavore
    Offline

    predavore Well-Known Member

    Likes Received:
    296
    Trophy Points:
    268
    Almost 2 weeks later, code has not come back. I feel like the ECU is like a little baby. Throws a code like a tantrum, then it's fine.
     
    Krazylegz1485 and tangledupinblu like this.

Share This Page