02 WRX security light flashing oddly. NOT VALET MODE.

Discussion in 'General Subaru Discussion' started by FlatBlackIan, Nov 10, 2010.

  1. FlatBlackIan
    Offline

    FlatBlackIan Active Member

    Likes Received:
    3
    Trophy Points:
    93
    First person to point me in the right direction gets a cookie.

    The security light on my 2002 Subaru WRX Sedan is doing something I have never seen before, and I have not been able to find any history of it ever happening to anyone.

    The car will not start. It has No spark, and No injector pulse. It will just crank all day long.

    The security light flashes either code 14, or 41. Flash Flash Flash Flash, pause, Flash, pause, Flash Flash Flash Flash, pause, Flash.

    I have tried unplugging the security box, and it just stops it from flashing.

    I have tested, and looked at everything I can think of for why the car will not start, and I keep coming back to this goofy security light issue.

    I have another thread in the tuning/maintenance thread, but no one has any clue about the light.

    Seriously people, a cookie, a really big cookie. I am at my wits end.

    The other thread. http://mnsubaru.com/forums/showthread.php/40335-02-WRX-no-spark-no-injector-pulse.
     
  2. JasonoJordan
    Offline

    JasonoJordan Well-Known Member

    Likes Received:
    1,697
    Trophy Points:
    398
    never-mind based on information posted on your other thread someone said 02 dosent have immobilizer.

    bad crank position sensor?
     
  3. FlatBlackIan
    Offline

    FlatBlackIan Active Member

    Likes Received:
    3
    Trophy Points:
    93
    Its not the crank sensor. Unless the air gap is too high, but I doubt it.

    The ecu is getting everything it needs, but not doing anything with it.

    I am an auto mechanic, I do this for a living. I'm no shlub at diagnostics either. I have checked everything I can with a dvom. I'm going to bring a lab scobe home, but I don't think it will help.

    Subaru is not very forthcoming about how the alarm systems work, so I can't troubleshoot it well.

    Any info regarding the security/keyless entey systems could be helpful. If there is anyone who works for subaru here, if you could check the service info only available to subaru techs, that would be glory.
     
  4. killzone
    Offline

    killzone New Member

    Likes Received:
    0
    Trophy Points:
    0
    Just curious, did ya find out a solution to this problem?